灌溉梦想,记录脚步
« »
2009 年 11 月 12 日关注学习

RouerOS DDNS 设置方法

先到www.changeip.com填写注册申请,并添加一个域名。

并在RouterOS的调度程序中添加下列代码:

:log info "DDNS: Begin"
:global ddns-user "你的用户名"
:global ddns-pass "你的密码"
:global ddns-host "*1"
:global ddns-interface "外网拨号线路,比如(pppoe-out3)"
:global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
:if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
:if ([ :typeof $ddns-ip ] = nil ) do={
:log info ("DDNS: No ip address present . " . $ddns-interface . ", please check.")
} else={
:if ($ddns-ip != $ddns-lastip) do={
:log info "DDNS: Sending Update!"
:log info [ /tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
:global ddns-lastip $ddns-ip
} else={
:log info "DDNS: No change"
}
}
:log info "DDNS: End"

日志信息 »

该日志于2009-11-12 14:58由 kevin 发表在关注学习分类下, 你可以发表评论。除了可以将这个日志以保留源地址及作者的情况下引用到你的网站或博客,还可以通过RSS 2.0订阅这个日志的所有评论。

没有评论

发表评论 »